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Customer Support

Technical Assistance
To search our knowledge base for a solution or to log in to the Technical Support
portal and report a problem, go to sps.honeywell.com.

Product Service and Repair
Honeywell International Inc. provides service for all of its products through service
centers throughout the world. Go to sps.honeywell.com and select Support to find a
service center near you or to get a Return Material Authorization number (RMA #)
before returning a product.

Limited Warranty
For warranty information, go to sps.honeywell.com and select Support > Productivity >
Warranties.
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GET STARTED

This chapter introduces the Device Finder application and includes the following
sections.

l About Device Finder

l Online Mode/Macro Positioning Mode

l Offline Mode/Micro Positioning Mode

l Key Features Comparison

About Device Finder
Device Finder is an application that allow users to locate their lost or misplaced
devices and avoid productivity loss and unnecessary capital expenditure. It is
recommended to use the solution in conjunction with Honeywell's Operational
Intelligence tool for increased simplicity, flexibility, and accuracy.

This document provides information on how to securely set up the solution and
explains the different features available. Refer to the FAQ section to find answers to
most common questions.
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Functional Overview
The Device Finder solution enables users with a Honeywell mobility device with the
app installed to track lost mobility devices based on either a Bluetooth beacon or the
locationing function in Operational Intelligence.

Note: Honeywell mobile computers with battery-based Bluetooth Low Energy (BLE) can
emit beacons during normal operation and even when the device is shut down until
the battery is drained completely.

Function Diagram

The Device Finder solution is offered in two modes to track and locate a lost device.

l Online Mode/Macro Positioning Mode using Operational Intelligence

l Offline Mode/Micro Positioning Mode using the Bluetooth beacon

Online Mode/Macro Positioning Mode
This mode allows zone level tracking and locating of the lost device by leveraging
Operational Intelligence’s Indoor Positioning Service (IPS) technology.

Working Principle

l The mobility devices must be enrolled in Operational Intelligence to leverage
the IPS feature, which enable the devices to be tracked at zone level.

l Once the devices are enrolled based on the rules configured in Operational Intel-
ligence, the devices can be put into lost status manually. The last known zone
location is captured. You can use the Device Finder application in another exist-
ing Mobility Edge device and log into the Operational Intelligence account.
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l Upon login, the list of lost devices with last known zone location is accessible to
the user.

l To track a lost device, you can go to the last known zone location and select the
device to be tracked from the list.

l If the lost device is emitting Bluetooth beacons, it can be tracked, and the
Device Finder shows the approximate distance of the device in different colored
circles.

a. Green (Almost there)

b. Yellow (Moving closer)

c. Orange (In range)

l Once you are in the nearby range, click on the bell icon to ring the device so
that the device can be located. Apart from ringing, the device can be configured
to vibrate, flash the screen and toggle the flash light.

l After the device is found, click on the Device Found button to set the device
back into active status in Operational Intelligence.

Online Mode
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Offline Mode/Micro Positioning Mode
This mode allows use of the Device Finder solution without Operational Intelligence
but reduces the chances of locating the device as zone level information is not
available, which increases the effort to search for a device in a broader area.

Note: You must register the device with Operational Intelligence to use this mode.

Working Principle

l Once the device is reported as lost, you can use the Device Finder application in
another existing Mobility Edge device (i.e., Finder device) to find the lost device.

l You can go to the last known location based on the information given by the
user who lost the device.

l Click the Search by ID icon, enter the serial number of the device to be located
in the search box, and tap Search.

l If the lost device is emitting Bluetooth beacons, it can be tracked, and the
Device Finder shows the approximate distance of the device in different colored
circles.

a. Green (Almost there)

b. Yellow (Moving closer)

c. Orange (In range)

l Once you are in the nearby range, click on the bell icon to ring the device so
that the device can be located. Apart from ringing, the device can be configured
to vibrate, flash the screen and toggle the flash light.

Offline Mode
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Key Features Comparison
Feature Online Mode Offline Mode

Search Area

Can be at a small zone level if
used along with Operational
Intelligence’s Indoor
Positioning feature.

Large

Effort to Locate Minimum Maximum

Settings
Configurable

Via Operational Intelligence,
EZConfig

EZConfig

Lost Devices List Yes
No, search by serial num-
ber only.

Application Updates
Remote update via Operational
Intelligence

Manual update via
Provisioner or MDM

Physical Indications
Ring, Vibrate, Screen flash,
Flashlight

Ring, Vibrate, Screen flash,
Flashlight

Operational
Intelligence
Registration

Required Not Required
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ONLINE SEARCH MODE

This chapter explains how to use the Device Finder application in Online Mode. The
chapter includes the following sections:

l Log into Operational Intelligence

l Device Management with Operational Intelligence

l Filter Device

l Track Lost Device

l Locate Lost Device

l Marking the Device as Found

l Error Screens
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Log into Operational Intelligence
The following requirements must be met to log into the Device Finder app in online
mode:

l Users must have an account in Operational Intelligence. User accounts must be
created by the Op Intel administrator.

l The finder device must be connected to Wi-Fi.

Log In
Launch the Device Finder app by tapping the icon on the device home screen then
enter the email address used in Op Intel and tap Continue.

Operational Intelligence Sign In
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Operational Intelligence Sign In Operational Intelligence Sign In with MFA

Enter your password for Op Intel and tap Sign In.

OR

If your site uses Multi-Factor Authentication (MFA), open the Microsoft Authenticator
app and enter the number displayed in Device Finder to continue logging in.
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Stayed Signed In

Tap Yes to stay signed into the Device Finder app on this device or No to be signed
out of the app after closing it.

Device Management with Operational Intelligence
Once you log into the Dashboard, you will be able to see the devices in the site and
their respective zone. The State column indicates if the device is Active or Lost.
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Operational Intelligence Dashboard

Search by Lost Status
On successful login, the Device Finder application lists information on lost devices
and their last known location from Operational Intelligence.

The Search by lost status screen displays all devices in an organization that have the
status as lost.

Device Finder User Guide 11



Device Finder Application Interface
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Search by ID
Use the Search by ID screen to locate a device by searching for the serial number.

Enter the serial number of the device then tap the Search button.

Search by ID
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Search by Site
Use the Search by Site screen to view the devices associated with a selected site.

Search by Site

Select the Search by site screen then select a site from the drop-down list. All devices
associated with the selected site will be listed along with the distance information.
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Devices out of range Devices within range

Expand a list to view devices out of range or devices within range.

The model, serial number, alias name, and zone location are displayed for each device.
If the zone is not known, "---" is displayed.

Devices within range displays the color indicating the device's distance (green for
close range, yellow for mid-range, or red for long range).
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Filter Device
You can filter the lost devices based on Device Model, Serial Number or Location.

l In the Device Finder application, click the search button at the top right corner.

l Provide the Model/Serial Number/Location of the lost device to be filtered in
the search bar shown below.

Device Finder Search Bar

Track Lost Device
For devices enrolled in Operational Intelligence, you can track the device using either
the signal from the Bluetooth Low Energy beacon (BLE) to move closer to its location
or by using the network signal to make the device buzz.

Select a device from the list of lost devices and go to the last known zone location.
After you select a device to find, the app indicates how close you are to it based on the
strength of the BLE beacon.

Information Screen
When you use the application for the first time, an information screen pops up as
shown below. You can select the “Don’t show again” option and then click the “GOT
IT” button to go to the tracking screen, or you can click the “X” icon at the top right
corner to skip this step. The green circle on this screen does not indicate actual
proximity to the device.
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Information Screen

Tracking Screen
In online mode, the Device Finder tracking screens for Search by lost status and
Search by site have two sections. (In offline mode, users can only access the Search
by ID screen):

l The BLE section indicates if the app is detecting the BLE signal and how close
you are to the lost device.

l The Network section indicates if the lost device is on the network and
connected to Op Intel.

When the finder device is in range of the lost device or the lost device is connected to
the network, the BUZZ DEVICE button will be active in that section. Tap the BUZZ
DEVICE button to cause the lost device to make an audible signal so that you can
locate it.

To use the Network-based alarm, both devices must be onboarded to Op Intel and in
Connected status, and both devices must be connected with Wi-Fi.

The following table shows possible options when tracking a lost device.
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View Description

BLE: The app is picking up the BLE
signal from the lost device.

Network: The lost device is connected
to the network and in Connected status
in Op Intel.

BLE: The app is picking up the BLE
signal from the lost device.

Network: The lost device is connected
to the network and in Connected status
in Op Intel; however, the finder device
does not have Wi-Fi. The BUZZ DEVICE
button is inactive under Network.
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View Description

BLE: The app is not picking up the BLE
signal from the lost device. Click TRY
AGAIN to search for the BLE signal.

Network: The lost device is connected
to the network and in Connected status
in Op Intel.

BLE: The app is not picking up the BLE
signal from the lost device. In this
example, the user has clicked TRY
AGAIN, and the app is searching for the
BLE signal.

Network: The lost device is not
connected to the network.
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View Description

Network: The lost device has been
located and is making an audible
signal.

Press STOP BUZZ to turn off the alarm
on the lost device.

Press MARK DEVICE AS FOUND to
update the status of the device from
"Lost" to "Active" in Op Intel.

Track by Bluetooth Low Energy Beacon (BLE)
To help you move in the right direction toward the lost device, the tracking system is
enabled with messages in the form of three different colored circles indicating how
close the finder device is to the lost device.

The three colored circles are:

a. Green (Almost there)

b. Yellow (Moving closer)

c. Orange (In range)

Understanding the Circles
When you start tracking:

l If the finder device is far but still in the range that it receives the beacon from
the lost device, then an orange circle is shown with the message “In Range.”
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l If the finder device is moving away from the lost device, an orange circle is
displayed with the message “Moving Out of Range.”

l If the finder device moves towards the lost device, then a yellow circle is dis-
played with the message “Moving Closer.”

l If the finder device keeps moving towards and reaches the proximity of the lost
device, then a green circle is displayed with the message “Almost There.”

l When the finder device is very near to the lost device, the green circle displays
the message "Very Close."

Device Finder Status Screen
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Locate Lost Device
Depending on how far you are from the lost device, the BUZZ DEVICE button or the
bell icon at the center of the circle might be inactive. When the bell icon is inactive, it
has a slash through the icon as shown in the below image. This indicates that there is
no communication link established between the finder device and the lost device.

Communication Link Status

l Once the communication link is established, either the BUZZ DEVICE button or
bell icon will be enabled.

l Once the bell icon is enabled, click on the icon to ring the device so that the
device can be located. Apart from ringing, the device can be configured to
vibrate, flash the screen and toggle the flash light.

Note: The ringing will stop automatically after one minute, and you need to tap the button
or bell icon again to ring it.

l The ringing can be stopped from the finder device by pressing the STOP BUZZ
button on the Search by lost status and Search by site screens or the bell icon
on the Search by ID screen.

l The ringing can be stopped from the located device by tapping the notification.

Beacon Transmitter Screen
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Marking the Device as Found
After the device is found, tap the DEVICE FOUND or MARK DEVICE AS FOUND button
to set the device back into Active status in Operational Intelligence.

Device Found Screen

Once the found device is updated as active in Operational Intelligence, the device gets
removed from the list of lost devices, and the State is updated to Active.

Operational Intelligence Screen

Device Finder User Guide 23



Error Screens
Lost Network

The following message will be displayed if the network connection is lost while in the
process of finding a lost device. Once the network connection is re-established, click
on the Refresh button to continue.

Network Error Screen

Device Not Found Error

If you try to search a lost device without being in the zone/range of the lost device, an
error is shown as below suggesting to move to a different zone.

Device Not Found Error Screen
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Lost Device Connection Error

The below error screen is displayed on the finder device if you move out of range of
the lost device.

Lost Device Connection Error Screen

Internet Connection Error

The following screen is displayed if there is no network connection.

Connection Error Screen
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Reports
Operational Intelligence provides reports on Lost and Found devices to track how
often devices are being lost and found in a given time period. The reports include
devices that were set to Lost status in Op Intel and devices that were marked as
Found by a user in the Device Finder app.

To access the report, log into Op Intel and select Event Reports from the main menu
then select "Lost and found devices" as the report type. Filtering options can be
applied to search for only lost or only found devices and to define the time period
included in the search.

For more information on reports, refer to the Operational Intelligence user guide
available at sps.honeywell.com.
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OFFLINE SEARCH MODE

This chapter explains how to use the Device Finder application in Offline Mode. The
chapter includes the following sections:

l Device Management in Offline Mode

l Locate Lost Device

l Error Screens

l Toggle Between Online and Offline Mode
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Device Management in Offline Mode
This mode allows the use of the Device Finder solution without Operational
Intelligence. It reduces the chances of locating the device as zone level information is
not available, which increases the effort to search for a device in a broader area.

Note: To use offline mode without requiring Op Intel login, configure the OIAuthentication
setting to bypass the Operational Intelligence login screens.

l Once the device is reported as lost, you can use the Device Finder application in
another existing Mobility Edge device (i.e., Finder device) to find the lost device.

l You can go to the last known location based on the information given by the
user who lost the device.

l Launch the Device Finder app and log in.

l Upon login, click the Search by ID icon, enter the serial number of the device to
be located in the search box, and tap Search.

Search by ID
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l If the lost device is emitting Bluetooth beacons, it can be tracked, and the
Device Finder shows the approximate distance of the device in different colored
circles.

a. Green (Almost there)

b. Yellow (Moving closer)

c. Orange (In range)

Device Finder Status Screen

Locate Lost Device
Once you start tracking the lost device, the bell icon at the center of the circle might
be disabled (striked off) as shown in the below screen. This indicates that there is no
communication link established between the finder device and the lost device.

Communication Link Status

l Once the communication link is established, the bell icon will be enabled.
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l Once the bell icon is enabled, click on it to ring the device so that the device can
be located. Apart from ringing, the device can be configured to vibrate, flash the
screen and toggle the flash light.

Note: The ringing will stop automatically after one minute, and you need to click on the bell
icon again to ring it.

l The ringing can also be stopped from the finder device by pressing the bell icon
once you locate the lost device, or it can be stopped from the located device by
tapping the notification.

Beacon Transmitter Screen

Note: The “Device Found” button is not available in Offline Search mode in the Device
Finder application.
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Error Screens
Device Not Found Error

If you try to search a lost device without being in the zone/range of the lost device or
if you enter a wrong serial number, an error is shown as below suggesting to enter a
correct serial number or move to a different zone.

Device Not Found Error Screen
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Lost Connection Error

The below error screen is displayed on the finder device if you move out of range of
the lost device.

Lost Connection Error Screen

l “TRY AGAIN” will try to search for the same device again and redirect to the
tracking screen.

l “BACK TO DEVICE LIST” will navigate to the offline search screen where you can
enter a different serial number.
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Toggle Between Online and Offline Mode
If there is no internet connectivity after the launch of the Device Finder application,
the app displays the following message:

No Network Message

l If you want to switch back to Search by Lost Status/Search by Site mode, you
can select the menu option available at the bottom of the screen.

l If you are in Search by Lost Status/Search by Site mode and want to switch to
Search by ID, you can select the Search by ID option at the bottom of the
screen.

Device Finder User Guide 33



Toggle Screen
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INSTALL COMPONENTS

This chapter explains how to install different components of Device Finder. The
chapter includes the following sections:

l Install Beacon Transmitter Service

l Start Beacon Transmitter Service

l Install Device Finder Application

l Launch Device Finder Application

Overview
The Device Finder solution is a combination of two system components, Beacon
Transmitter service and Device Finder application.

Beacon Transmitter service emits beacons at an interval of one second. These are
connectable beacons which broadcast model number and serial number of the device
in which it runs. It is a background service which can run on all devices that need to
be tracked and by default it is turned off.

Device Finder is an application which finds lost devices via scanning and tracking
beacons emitted by devices running the Beacon Transmitter service.

SSClient
SSClient is the Op Intel agent and is used to configure mobile computers that are
onboarded in Operational Intelligence. To use the Device Finder alarm feature in
online mode, devices must have a version of the SSClient.apk greater than
5.12.03.0227.

The following maintenance releases (MR) include SSClient version 5.13.00.0001 and
can be used directly with Device Finder:
MR23 P(A09), MR19 Q(A10), and MR14 Hon660 R(A11) .

Android versions and maintenance releases higher than these will include the
required SSClient version.

For earlier Android versions, SSClient version 5.12.03.0227 must be installed on the
device. The SSClient apk can be downloaded from honeywell.com/PSSsoftware-
downloads under Software > Software and Tools > Device Management > SSClient -
Operational Intelligence.
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Install Beacon Transmitter Service
The BeaconTransmitter.apk needs to be installed on all Mobility Edge devices which
need to be tracked. This section explains on how to update Beacon Transmitter on
Android Pie MR08 OS or higher and on Android Oreo MR25 OS or higher.
For support on earlier releases, refer to Miscellaneous information.

You can install the Beacon Transmitter service via the following methods:

l Operational Intelligence

l Enterprise Provisioner

l Autoinstall

l Adb Command

Operational Intelligence
Update the apk using software update procedure and transfer the
“BeaconTransmitter.apk” to Mobility Edge devices on which Beacon Transmitter
service needs to be installed.

l Log in to Operational Intelligence and go to the Software Updates tab.

Operational Intelligence Screen
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l Click on Upload Software to update Beacon Transmitter. Select File Type as
Application (Apk file).

Beacon Transmitter Update Screen

l Upload FMD.xml to cloud.

l Select File Type as Device Configuration file.

Note: FMD.xml can be exported from Enterprise Provisioner (EP). Refer to Export FMD.xml
from Enterprise Provisioner.

Upload FMD.xml Screen
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Export FMD.xml from Enterprise Provisioner
Go to Software Updates and click on Enterprise Provisioner at the top right corner of
the screen as shown.

Operational Intelligence Screen

In Enterprise Provisioner, select Operational Intelligence Apps for the Device settings
package.

Enterprise Provisioner Screen
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Go to Settings > FMD > FMDTransmitter. Enable Start Or Stop Service.

FMD Transmitter Option

Go to Export Options, select FMD and click on Export. This exports the FMD.xml to
your PC.

Export Options
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Export DeviceConfig.xml from Enterprise Provisioner
Select a MR bundle related to the OS and select DeviceConfig. Change the settings as
below.

l Enable Bluetooth

l Set the location mode to High accuracy

Bluetooth and Location Settings

Go to Export Options, select DeviceConfig and click on Export. This exports the
DeviceConfig.xml to your PC.

Export Options
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Note: To upload Deviceconfig.xml to cloud, follow the same steps as Upload FMD.xml to
cloud.

Create a bundle in Enterprise Provisioner
Go to Software Updates and click on Enterprise Provisioner at the top right corner of
the screen as shown.

Operational Intelligence Screen

In Enterprise Provisioner, click on the Provisioning Tab and select Choose cloud files.

Provisioning Tab
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Select FMD.xml, Beacontransmitter.apk, Deviceconfig.xml files and click on IMPORT.

Import Screen

Once Imported, three tasks are created in Enterprise Provisioner. Arrange the tasks in
the sequence shown below.

Import Sequence
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Navigate to Export options, select Tasks and click on Export.

Export Bundle

Provide a desired name for the bundle and click OK to create the bundle.

Name the Bundle
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In Operational Intelligence, select the BeaconTransmitter_Bundle and click on the
Update option in the toolbar.

Update Bundle
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Select the devices and click on Update to push the bundle to the devices.

Push Bundle to Device

Operational Intelligence Screen
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Enterprise Provisioner
To install the Beacon Transmitter service through Enterprise Provisioner:

Go to Enterprise Provisioner > Provisioning > Create Task > Application Package (APK)
(Generate barcode) > In Source Path Option > Add URL to download the apk from the
server location - http/ftp.

Autoinstall
To autoinstall the Beacon Transmitter service on a device:

l Turn on Provisioning mode manually through Settings > Honeywell Settings or
MDM.

l Use one of these options to copy the apk file to
\IPSM Card\Honeywell\AutoInstall or
\Internal Storage\Honeywell\AutoInstall

l Manually connect to the system and enable File Transfer mode

l Mobile Device Management (MDM)

l Enterprise Provisioner > Provisioning > Create Copy File Task

l Reboot the device.

Abd Command
To install the Beacon Transmitter service through Abd Command, use abd install
BeaconTransmitter.apk.
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Start Beacon Transmitter Service
To start Beacon Transmitter Service with Operational Intelligence in Enterprise
Provisioner, you must configure FMD.xml and enable the start option.

l In Enterprise Provisioner, select Operational Intelligence Apps bundle for Device
settings package and navigate to FMD.

l Go to FMDTransmitter > StartOrStop Service > Enable.

l Go to Export options, select the application whose xml needs to be imported.
Choose FMD and click the export button to generate and download the con-
figuration file to your PC.

Enterprise Provisioner Screen
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Upload XML to Operational Intelligence
Log in to Operational Intelligence and go to the Software Updates tab.

Operational Intelligence Screen

Click on Upload software, select File Type as Device Configuration file and upload the
FMD.xml file.

Upload FMD.xml Screen
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Push FMD.xml to Devices
Select the FMD.xml file and click on Upload.

Update Bundle

Select the devices and click on Update option in the toolbar.

Device Selection Screen
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This screen appears once the file is pushed to the device.

Bundle Pushed to Device

Enable Beacon Transmitter Service with EZConfig
To enable EZConfig, launch Power Tools from All Apps menu and then launch
EZconfig.

In EZConfig, click on at the top left corner.

EZConfig Application
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Select Generator and open FMD.xml.

EZConfig Files

In FMD settings, navigate to FMDTransmitter then select StartOrStop Service and
enter the value as 1.

Navigation in FMD 
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Click on Save and then Update Configure.

Save Settings

Beacon Transmitter service notifies that the application has started transmitting
beacons.

Beacon Transmitter Notification
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Install Device Finder Application
You can install the Device Finder application (BeaconDirection.apk) on existing
Mobility Edge devices which can be used to track and find lost devices.

Install the Device Finder application via one of the following methods.

Operational Intelligence
To install the Device Finder application, update the BeaconDirection.apk and
DeviceConfig.xml as described in the section “Install Beacon Transmitter Service”
using the software update procedure and pushing the bundle through Operational
Intelligence.

Note: Instead of BeaconTransmitter.apk use BeaconDirection.apk for the Device Finder
application installation.

Enterprise Provisioner
To install the Device Finder application through Enterprise Provisioner:

Go to Enterprise Provisioner > Provisioning > Create Task > Application Package (APK)
(Generate barcode) > In Source Path Option > Add URL to download apk from the
server location - http/ftp.

Autoinstall
To autoinstall the Device Finder application:

l Turn on Provisioning mode manually through Settings > Honeywell Settings or
MDM.

l Copy the apk file to \IPSM Card\Honeywell\AutoInstall or
\Internal Storage\Honeywell\AutoInstall using one of the following methods:

l Manually connect to the system and enable File Transfer mode

l Mobile Device Management (MDM)

l Enterprise Provisioner > Provisioning > Create Copy File Task

l Reboot the device.

Abd Command
To install the Device Finder application through Abd Command, use abd install
BeaconDirection.apk.
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Launch Device Finder Application
Click on to launch the Device Finder application on the finder device. If internet
connectivity is available, a login screen will be displayed. If there is no internet
connection, you will receive a pop up on your screen to connect to the internet.
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CONFIGURE AND MANAGE

This chapter explains how to configure the Device Finder application by editing the
FMD.xml configuration file from Operational Intelligence. The chapter includes the
following sections:

l Configurable Settings in Beacon Transmitter Service

l Common Configurable Settings

l Configure Settings in Enterprise Provisioner via Operational Intelligence
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Configurable Settings in Beacon Transmitter Service
FMD.xml has the following configurable options:

Settings in Beacon Transmitter Service

Start or Stop Service
Use this setting to start or stop Beacon Transmitter Service.

Possible values are:

l 1 to start the service

l 0 to stop the service.

Default Value

0

Primary RSSI@ 1M
Use the slider to set the value for the setting. Move the slider towards right side to
increase the value and move the slider towards left side to decrease the value.

The valid value ranges between -120 and -10.

Default Value

-59
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Secondary RSSI@ 1M
Use the slider to set the value for the setting. Move the slider towards right side to
increase the value and move the slider towards left side to decrease the value.

The valid value ranges between -120 and -10.

Default Value

-61

Tx Power Level
Set the Transmission Power by selecting a value from the drop-down list provided.

Possible values are:

l High

l Medium

l Low

Default Value

High

Beep
This setting will ring the lost device when the bell icon is pressed in the Device Finder
application from the finder device.

Possible values are:

l 1 to enable the ring

l 0 to disable the ring

Default Value

1

Vibrate
This setting will vibrate the lost device when the bell icon is pressed in the Device
Finder application from the finder device.

Possible values are:

l 1 to enable the vibration

l 0 to disable the vibration

Default Value

0
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Flash Light
This setting will turn on flash light on the lost device when the bell icon is pressed in
the Device Finder application from the finder device.

Possible values are:

l 1 to enable the flash light

l 0 to disable the flash light

Default Value

0

Note: This feature is only applicable for devices that support camera flash light. For devices
without this feature, the values 0 or 1 will not have any impact.

Screen Light
This setting will flicker the screen on the lost device when the bell icon is pressed in
the Device Finder application from the finder device.

Possible values are:

l 1 to enable the flickering

l 0 to disable the flickering

Default Value

0

Enable Transmitting Beacons in Charging
This setting allows you to enable or disable transmission of beacons based on the
device power state.

You can set the value as 1 to enable transmitting beacons and 0 to stop transmitting
beacons in charging mode.

Possible values are:

l 1 to enable transmitting beacons

l 0 to disable transmitting beacons

Default Value

1
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Write Serial Number to Second Ble
This setting writes the device's serial number to the second Bluetooth Low Energy
beacon. Applicable only for devices with second BLE.

Possible values are:

l 1 to enable writing the serial number to the second BLE

l 0 to disable writing the serial number to the second BLE

Default Value

0

Write Device Model to Second Ble
This setting writes the device model to the second Bluetooth Low Energy beacon.
Applicable only for devices with second BLE.

Possible values are:

l 1 to enable writing the device model to the second BLE

l 0 to disable writing the device model to the second BLE

Default Value

0

Scan Time for Range
This setting configures the scan time in seconds to find the range of the device.

Valid values range from 1 to 300.

Default Value

120
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OIAuthentication
This setting determines if the user must log in with Op Intel credentials or if the Op
Intel login screens are bypassed.

Possible values are:

l 0 to require Op Intel Authentication

l 1 to bypass Op Intel login screens

Default Value

0

Note: The lost devices that are displayed on the Search by lost status tab depend on
the setting for OIAuthentication.

l When OIAuthentication is set to 1, the Search by lost status tab will display all
devices that are marked as lost, have location details, and are in the same Site
as the finder device.

l When OIAuthentication is set to 0, the Search by lost status tab will display all
devices that are marked as lost, have location details, and are in the same
Organization as the user's last Op Intel login.

Common Configurable Settings
Following are the common configurable settings between the Device Finder
application and Beacon Transmitting service.

Common Settings
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Pass Key
This option is used to set a Pass Key for a secure communication over the Bluetooth
network between the finder device and lost device. A maximum of 19 characters are
allowed for the Pass Key and it will be stored in an encrypted format.

If you do not provide a value for the setting, the device will use the default value.

Show Notifications
This setting allows you to disable application generated notifications.

Set the value as 1 to show notifications and 0 to hide notifications.

Default Value

1

Configure Settings in Enterprise Provisioner via
Operational Intelligence

To configure settings through Enterprise Provisioner:

l Open the Enterprise Provisioner application on your computer.

l Go to File > Import > Load > FMD.xml.

Configure Settings via EP

l Configure settings as required.

l Export the XML to push to the device or generate barcode and scan.
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ADDITIONAL INFORMATION

This chapter explains how the Device Finder application handles different scenarios
like Bluetooth ON/OFF, Network ON/OFF, and Exit Application. The chapter includes
the following sections:

l Bluetooth ON/OFF in Device Finder Application

l Network ON/OFF in Device Finder Application

l Back Key Press/Exit Application in Device Finder

l Bluetooth ON/OFF with Beacon Transmitter Service

l Find Version Details
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Bluetooth ON/OFF in Device Finder Application
If the Device Finder application cannot find network connectivity upon launch, it will
redirect to Offline Search mode.

If Bluetooth is off after launching the application or if Bluetooth is disabled while
tracking a lost device, you will receive a pop up prompting you to enable Bluetooth.

Bluetooth OFF at Launch Bluetooth OFF while Tracking
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Network ON/OFF in Device Finder Application
If the Device Finder application cannot find network connectivity upon launch, you
will receive a pop up on your screen to connect to the internet.

If network connectivity fails while loading the login page or while signing in, you will
receive a pop up to choose to either refresh the page or switch to Offline Search
mode.

Network Unavailable while Signing In
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If there is no network connectivity while fetching the list of the lost devices from the
cloud, you will see the below screens.

Internet/Wi-Fi Unavailable

If you try to switch from Offline Mode to Online Mode without a network connection, a
message will be displayed asking you to check the network connection and try again.

Network Unavailable While Switching Modes
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Back Key Press/Exit Application in Device Finder
You can press the Back key in the Login screen/Lost devices list screen/Offline
search screen to exit the Device Finder application.

To make sure the user really wants to exit the application and has not pressed the
Back key by mistake, a confirmation message is displayed as shown in the below
figures.

Note: Pressing the Back key in other screens will take you back to the previous screen.

Back Key Press Functionality
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Bluetooth ON/OFF with Beacon Transmitter Service
Beacon Transmitter Service is a background service without any user interface. All
updates and events are shown as notifications. If Bluetooth is turned off when Beacon
Transmitter Service is active, then you will see the below notification.

Beacon Transmitter Notifications

Find Version Details
Device Finder Application

Version details for the Device Finder application can found by tapping the three bars
at the top left corner of the screen.

Device Finder Version Details

Beacon Transmitter Service
To find the version details of Beacon Transmitter Service:

Go to Power Tools > Diagnostic Information > System Info > BeaconTransmitter.
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Beacon Transmitter Version Details
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FREQUENTLY ASKED
QUESTIONS (FAQ)

This section provides answers to some common questions about the Device Finder
app. For specific information about the Honeywell mobility device you are using, refer
to the device user guide or data sheet available at sps.honeywell.com.

1. What will happen if my lost device is in sleep mode?

You can still search and ring the device. The lost devices will send Bluetooth
beacons even when it is in sleep mode.

2. What will happen if my lost device is switched off?

Devices with battery based BLE will continue to send beacons until the battery
is fully discharged, so for the user carrying the Device Finder application, there
won’t be any difference if the lost device is on or off.

3. How long does the lost device send the BLE beacon after it goes into shut-
down?

The hardware beacon will run on the super capacitor and will send the beacons
up to ~5 days.

Refer to the specifications for your device to determine if it has battery based
BLE, which has the ability to send beacons until the battery is fully discharged.

4. What is the battery consumption of the Beacon Transmitter Service?

Battery consumption is very low, approximately 0.02%/hr during sleep and
0.11%/hr during normal operation.

5. What is the difference between CT40XP and CT40 Beacon Operation?

Beacon Operation
Information

Main Battery Main Battery for 2nd BLE

CT40 > 3.2V (Prim BLE) N/A

CT40XP > 3.2V (Prim BLE) 3.2V-2.815V (2nd BLE)

Beacon Operational
Time

> 12 hrs 5 days
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6. How secure is our connection?

Any connection and data exchange related to Device Finder will only happen
between the lost device and the finder device if they have the same pass key.
This ensures that only authenticated devices are connecting with each other.

7. What will happen if the pass key is different in the lost device and the finder
device or if a pass key is pushed from the cloud while a lost device is switched
off?

If the pass key does not match, no communication will happen between a lost
device and the finder device.

Devices will be able to communicate using up to five previous pass keys. This is
designed to cover scenarios where the lost device switches off or gets
disconnected from the network and then the pass key is updated.

8. Does Device Finder handle Bluetooth Replay Attack?

A Replay Attack occurs when a hacker eavesdrops on a secure network
communication, intercepts it and fraudulently delays or resends it to misdirect
the receiver into doing what the hacker wants. In this case, it can listen and
resend the payload.

Device Finder handles Bluetooth Replay Attack by generating a unique key for
each connection, which means every connection will have its own unique
random key. If hackers try to copy raw payload data from a connection and
resend, the attack will fail.

Note: For additional information on securing an Android device, refer to the Android
Network and Security Guide available at sps.honeywell.com.

9. How accurate is the Range Calculation?

Range may get impacted by things like being in between walls or near
computers, tables, etc. That is why distance ranging circles are shown, which
will not mislead users.

10. Can I only ring the device when I am in the Green Circle?

No, you can ring the lost device as soon as your bell icon is enabled no matter
which circle you are in; however, ringing will be more audible when you are in
the green circle, i.e., near a lost device.

11. What configurable options are available?

You can configure pass key, transmission power and actions to be performed
when a lost device is found like Ring (default) , Vibrate, Flicker Flash Light ,
Flicker Screen Light, etc.

12. Which devices/OS Versions are supported?

The following Mobility Edge devices are supported with Android 9 or
higher: CT30 XP, CT40 XP, CT45, CT45 XP, CK65, CT47.
The following Mobility Edge devices are supported with Android 8 or higher: 
CN80, CT40, CT60, CT60 XP, RT10A, VM1A.
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13. What are the MRs supported in this feature?

Refer to the table "OS Comparison " on page 76 from Miscellaneous information
for MR information.

14. Where can I get the Device Finder Apk?

To download the latest version of the Device Finder Apk:

l Go to honeywell.com/PSSsoftware-downloads.

l Navigate to Software > Software and Tools > Locationing Solutions.
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MISCELLANEOUS
INFORMATION

This chapter explains how to install different components of Device Finder for
releases prior to Android 9 MR08 and Android 8 MR25 on Mobility Edge
devices and for Android 9 MR17 on ScanPal EDA61K devices with Operational
Intelligence.

The chapter includes the following sections:

l OS Comparison

l Install Beacon Transmitter Service for Earlier OS Releases

l Install Device Finder Application for Earlier OS Releases
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OS Comparison
For devices on Android 10 and higher, the Device Finder app is verified on all
maintenance releases (MR) for all supported devices.

The following table provides information on version requirements for devices
on Android 8 and 9.

Devices Android 9 Android 8

Mobility Edge
Devices (CT40,
CT45, CT60,
CN80, CN85, and
CK65)

l For MR08 and above -
No commonES upgrade
needed.

l For MR05 to MR07 -
commonES needs to be
upgraded 9.00.00.6345.

l For MR04 and below -
Not supported.

l For MR25 and above
- No commonES
upgrade needed.

l For MR24 and below
- CommonES needs
to be upgraded to
8.01.05.6410.

ScanPal EDA61K

l For MR 17 and above -
No commonES upgrade
is needed.

l For MR 16 -
CommonES needs to be
upgraded 9.02.01.5918.

l MR 15 - Not supported.

Note: For Android 9 releases prior to MR05, the Operational Intelligence method
update is not possible as the Provisioner in earlier MR does not support
Operational Intelligence bundle download.

Note: It is advised to use the OTAs which support the Device Finder instead of
upgrading the commonES.
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Install Beacon Transmitter Service for Earlier OS
Releases

Update the apk using software update procedure and transfer the
“BeaconTransmitter.apk” to Mobility Edge devices on which Beacon
Transmitter service needs to be installed.

Log in to Operational Intelligence and go to the Software Updates tab.

Operational Intelligence Screen

Click on Upload Software to update CommonES package to cloud.

Select the File type as CommonES Package, Device type as Mobile Computers,
and enter a name in the Update name field as below.

l CommonES for Pie: 9.00.00.6345

l CommonES for Oreo: 8.01.05.6410

Beacon Transmitter Update Screen

Click on Browse Files and select files to upload.
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Upload Screen

CommonES file will be updated in the Updates tab.

Operational Intelligence Screen
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Click on Upload Software to update Beacon Transmitter. Select File Type as
Application (Apk file).

Beacon transmitter Update Screen

Upload FMD.xml to cloud.

Select File Type as Device Configuration file.

Note: FMD.xml can be exported from Enterprise Provisioner (EP). Refer to Export
FMD.xml from Enterprise Provisioner.

Upload Screen
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Export FMD.xml from Enterprise Provisioner
Go to Software Updates and click on Enterprise Provisioner at the top right
corner of the screen as shown.

Operational Intelligence Screen

In Enterprise Provisioner, select Operational Intelligence Apps for the Device
settings package.

Enterprise Provisioner Screen
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Click on FMDTransmitter and enable Start Or Stop Service.

FMD Transmitter Option

Go to Export Options, select FMD and click on Export. This exports the
FMD.xml to your PC.

Export Options
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Export DeviceConfig.xml from Enterprise Provisioner
Select a MR bundle related to the OS and select DeviceConfig. Change the
settings as below.

l Enable Bluetooth

l Set the location mode to High accuracy

Bluetooth and Location Settings

Go to Export Options, select DeviceConfig and click on Export. This exports the
DeviceConfig.xml to your PC.

Export Options
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Note: To upload Deviceconfig.xml to cloud, follow the same steps as Upload FMD.xml
to cloud.

Create a bundle in Enterprise Provisioner
Go to Software Updates and click on Enterprise Provisioner at the top right
corner of the screen as shown.

Operational Intelligence Screen

In Enterprise Provisioner, click on the Provisioning tab and select Choose cloud
files.

Provisioning Tab
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Select FMD.xml, Beacontransmitter.apk, Deviceconfig.xml, and
Honeywell_CommonES_Android_Engineer_<version>.zip file as shown below
and click on IMPORT.

Import Screen

Once imported, four tasks are created in Enterprise Provisioner. Arrange the
tasks in the sequence shown below.

Import Sequence
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Create Task "Delay"
Click on the Task tab and enter 60000 ms (i.e., 60 seconds) for Delay.

Create Task

Rearrange the tasks as shown in the following image.

Note: For Android Oreo, the Delay task creation is not applicable. So, the Delay task is
skipped for Android Oreo from the below sequence.

Rearrange Tasks
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Navigate to Export options, select Tasks and click on Export.

Export Bundle

Enter a desired name for the bundle and click OK to create the bundle.

Name the Bundle
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In Operational Intelligence, select the BeaconTransmitter_Bundle and click on
the Update option in the toolbar.

Update Bundle
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Select the devices and click on Update to push the bundle to the devices.

Push Bundle to Device

Operational Intelligence Screen
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Install Device Finder Application for Earlier OS
Releases

To install the Device Finder application, update the BeaconDirection.apk and
DeviceConfig.xml as described in the section "Install Beacon Transmitter
Service for Earlier OS Releases" using the software update procedure and
pushing the bundle through Operational Intelligence.

Note: Instead of BeaconTransmitter.apk use BeaconDirection.apk for the Device
Finder application installation.
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